ExplorerClone bug

The place for threads about version 1.x of TimoSoft ExplorerTreeView.
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

ExplorerClone bug

Post by Esquisse »

Hello,

Nice job ! I find a bug in the sample ExplorerClone. When we make a copy/paste the operation is effective but make crash the application :(

Also is it possible to get the context menu on foreground of the listview like the tree one (same as windows in fact) ?

Configuration :
Version : Latest as today
Os : Windows 2000 SP4

;)
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: ExplorerClone bug

Post by TiKu »

Hi,
Esquisse wrote:I find a bug in the sample ExplorerClone. When we make a copy/paste the operation is effective but make crash the application :(
So far I have not been able to reproduce this behavior. Does this happen with other samples as well?
Esquisse wrote:Also is it possible to get the context menu on foreground of the listview like the tree one (same as windows in fact) ?
I'm not sure I understand you correctly. Does the listview hide the context menu? Everything seems to work on my Windows 2000 SP4. Could you please somehow make a screenshot of what you mean and post it here?
Or do you mean the context menu that is displayed when you click on the listview's background (it contains "New" and maybe some other items). Well, this menu is indeed incomplete. Unfortunately you can't retrieve this menu entirely from the shell. Items like "Copy" and "Paste" must be added "by hand". If I find some time, I'll update the sample to do this. Maybe I'll also use the opportunity and replace vbAccelerator's listview with my own (the vbAccelerator listview has many bugs).

Kind regards
Timo
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

bug

Post by Esquisse »

The problem appears with all sample when i try to copy/paste a file. I attached the really explicit message ;)
Attachments
timsoft.png
(3.19 KiB) Downloaded 750 times
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

This looks like a problem with AutoUpdate. To locate the problem I need more info:
- Do you copy within the ExplorerTreeView sample or do you use Microsoft Windows Explorer (while the sample is running)?
- Which folder do you copy from?
- Which folder do you copy to?
- Which file do you copy?
- Does it happen when you copy 1 file or only if you copy multiple files at once?

Also could you please download the attached program, start it before copying, make ExplorerTreeView crash and post the program's output here?
Attachments
SHChangeNotifications.zip
(8.86 KiB) Downloaded 641 times
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

Post by Esquisse »

With this example I :

- Launch the project into Visual basic
- Run it
- Go to d:\
- Right click on "telephone portable.xls"
- Copy
- go to "d:\!Ecole"
- Right click on the treeview's item "d:\!ecole\"
- Paste
- The file is copying and the error message.


The log is :


Just start changing things in any Explorer window...
(i.e. rename/move/create/delete any file or folder,
change a file's association, insert/remove a CD,
add/remove a network share, etc...)

All shell notifications will be listed here...

SHCNE_DELETE
first item displayname: ExplorerClone.vbp
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.vbp.lnk

SHCNE_CREATE
first item displayname: ExplorerClone.vbp
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.vbp.lnk

SHCNE_UPDATEITEM
first item displayname: ExplorerClone.vbp
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.vbp.lnk

SHCNE_FREESPACE
C:\

SHCNE_CREATE
first item displayname: ExplorerClone.vbp
first item path:

SHCNE_CREATE
first item displayname: ExplorerClone.vbp
first item path:

SHCNE_CREATE
first item displayname: ExplorerClone.vbp
first item path:

SHCNE_DELETE
first item displayname: ExplorerClone
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.lnk

SHCNE_CREATE
first item displayname: ExplorerClone
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.lnk

SHCNE_UPDATEITEM
first item displayname: ExplorerClone
first item path: C:\Documents and Settings\Windows 2000\Recent\ExplorerClone.lnk

SHCNE_FREESPACE
C:\

SHCNE_UPDATEDIR
first item displayname: ExplorerClone
first item path: D:\Download\extvw_samples2\ExplorerClone

SHCNE_CREATE
first item displayname: telephone portable.xls
first item path: D:\!Ecole\telephone portable.xls

SHCNE_FREESPACE
D:\
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

I'm still not able to reproduce the crash, but that's more or less normal, that the Windows shell notification system works slightly different on each PC.
So I'm afraid all I can do is watch my code, more or less guess where the crash happens and try to fix it. Don't expect a bugfix too soon, sorry.
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

Hi,

I finally found time to work on this issue. Because I can't reproduce the crash on none of my systems, I'll need some assistance from you.
At first we've to find out which of the shell events causes the crash. In the attached build, SHCNE_CREATE and SHCNE_DELETE are not handled. So if it still crashes, it's very likely that SHCNE_UPDATEDIR is the reason.
Please test the attached build and tell me if it is still crashing.

Timo
Attachments
ExTvw660.zip
Doesn't handle file/folder creations/deletions - just for debugging.
(234.64 KiB) Downloaded 618 times
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

Post by Esquisse »

It crashed again.
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

Okay, so this one hopefully doesn't crash. I've activated SHCNE_CREATE and SHCNE_DELETE again and deactivated SHCNE_UPDATEDIR. SHCNE_FREESPACE isn't handled anyway.
Attachments
ExTvw.zip
Doesn't handle SHCNE_UPDATEDIR - just for debugging.
(234.75 KiB) Downloaded 646 times
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

Post by Esquisse »

It also crash.

Is there anyway to put msgbox on each code's lines like :

msgbox "1"
test = test & "xxx"
msgbox "2"

etc... It would be faster
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

You're absolutely right. :)
The attached build will popup a MsgBox before it handles one of the involved events and one afterwards. Inbetween those two message boxes you should get other message boxes telling which code succeeded so far and what some important variables are set to.

If the program crashes between a "received SHCNE_*" and the corresponding "handled SHCNE_*" message, I need all messages of this "received"/"handled"-block.
If it crashes outside such a block, we've a problem I guess. ;)
Attachments
ExTvw661.zip
Will popup message boxes on certain AutoUpdate events - just for debugging.
(236.51 KiB) Downloaded 611 times
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

Post by Esquisse »

Hello,

Msgboxes are :

Recieved SHCNE_CREATE : file.txt
Handled SHCNE_CREATE : file.txt
[Crash]

Note : if i make 'copy' from Windows explorer, then 'paste' in ExplorerClone, it doesn't bug.
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

That's strange. Just to make sure it really is AutoUpdate that is causing the crash, I've disabled it completely. So if this build still crashes, it's not AutoUpdate.
Attachments
ExTvw662.zip
Disabled AutoUpdate - just for debugging
(236.49 KiB) Downloaded 669 times
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Esquisse
Cadet
Posts: 10
Joined: 19 Nov 2005, 23:00

Post by Esquisse »

It's also crashing :'(
User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Post by TiKu »

Damn, then it could be everything and nothing. Could you please test some older builds while I search for another possible source of the problem? Maybe some recent change is responsible.
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!
Post Reply