DisabledBackColor does not work

The place for threads about TimoSoft EditControls.
Post Reply
CraigBurke
Cadet
Posts: 4
Joined: 23 Nov 2015, 23:30

DisabledBackColor does not work

Post by CraigBurke » 23 Nov 2015, 23:43

Hi,

I am using Visual Foxpro and trying to use the textbox v1.9.2.186 .
All works well except setting the DisabledBackColor does not work.
I am setting it at runtime.

Thanks for the great controls!!

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: DisabledBackColor does not work

Post by TiKu » 24 Nov 2015, 19:16

Which version of Windows are you using? Does your application use Windows themes, i.e. does it use a manifest?
It works for me on Windows 7, but I don't have access to Visual FoxPro and can test with Visual Basic 6 only.
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

CraigBurke
Cadet
Posts: 4
Joined: 23 Nov 2015, 23:30

Re: DisabledBackColor does not work

Post by CraigBurke » 26 Nov 2015, 03:05

Windows 7. All forms and application are set with themes = true.
I want to override these colors so that there is consistency on all other OS(s) also.

I turned themes off on the form just as a test with no success. Another thing I noticed is that the background does not change when you set Enabled = false, it only changes when you set ReadOnly = False, though you can't change the color.

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: DisabledBackColor does not work

Post by TiKu » 26 Nov 2015, 07:56

Seems like FoxPro behaves quite different from VB6. Can you please send me a compiled test project that reproduces the problem, so that I can use it to try finding a fix?
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

Post Reply