Unicode IME Does Not Work

The place for threads about TimoSoft EditControls.
Post Reply
surfer_del
Cadet
Posts: 4
Joined: 14 Oct 2011, 14:06
Contact:

Unicode IME Does Not Work

Post by surfer_del » 14 Oct 2011, 14:12

Hi!
First of all i appreciate Tiku to make such incredible controls for VB6 and keeps it alive.

Tiku i have using your control first time for Indian Languages whenever i try to input unicode charaters through Microsoft ILIT Keyboard Layout it shows ??? (question marks).

but when i copy and paste the unicode text it display fine.

is there any settings in controls. or its a bug and also provide some code sample if you can.
once again
i am very greatfull to you.

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Unicode IME Does Not Work

Post by TiKu » 14 Oct 2011, 15:47

Hi,

This is a known problem. Hindi is a language that does not work well with my controls. I do not know the reason, but I assume it is because the VB6 main window itself still is ANSI. If I remember correctly, Hindi IME works correctly if the control is used inside a Unicode C++ application - this supports my assumption.
If you have any idea how I could make the IME think that a VB6 Form is a Unicode window, please let me know. I'd love to fix this problem.

Thanks for your commendations. You are welcome.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

surfer_del
Cadet
Posts: 4
Joined: 14 Oct 2011, 14:06
Contact:

Re: Unicode IME Does Not Work

Post by surfer_del » 15 Oct 2011, 06:32

dear Tiku,

I really apreciate to your concern about your controls and contribution to the developers. you are right VB6 is ANSI. have you seen hexagora unicode controls these controls works fine with Indian IME or others. you should check its trial version.

i think you have to hook the keyboard before it send input to VB6 input handler because it converts unicode characters to ANSI you have to trap those characters and put into your edit controls after that every language will work smoothly, it will work fine.

i have very few knowlege about C++ and windows core api you can also try Microsoft NLS API.

i hope to find a better solution from your side. after that your controls will be boom only this particular area needs a work otherwise your controls are supberb and no body will compete because you are providing its free but i hope one you will get more benifits of your hardwork.

i want to know more about you

thanks

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Unicode IME Does Not Work

Post by TiKu » 15 Oct 2011, 20:01

I'll try whether a hook will help. But don't expect new controls with a solution for this problem soon. I don't have much time anymore to work on the controls. Also there are several problems to solve:
  • If each instance of one of my controls installs a hook, this will probably lead to performance issues. Therefore the hook should be done in a more centralized way, maybe with a special control which also implements some other stuff to make a VB6 form more Unicode.
  • It could become difficult to provide all the events in the same way as in current versions while using a hook to work around the normal window messages processing.
Many thanks for your suggestions.
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

surfer_del
Cadet
Posts: 4
Joined: 14 Oct 2011, 14:06
Contact:

Re: Unicode IME Does Not Work

Post by surfer_del » 19 Oct 2011, 09:49

dear tiku,

many thanks for your instant replies. i am building a application to search database with unicode support. i am stucked here becuase hexagora controls are expensive and i can pay because this is not commercial version. i need a free or much cheaper solution. if you have any suggestion please give me. i will be greatfull to you.

i didnt find your profile anywhere please provide me your profile also

greeting from my side.

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Unicode IME Does Not Work

Post by TiKu » 19 Oct 2011, 11:53

Hi,

which kind of profile do you mean?
I'm sorry, but currently I don't have any suggestion that could help you.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

surfer_del
Cadet
Posts: 4
Joined: 14 Oct 2011, 14:06
Contact:

Re: Unicode IME Does Not Work

Post by surfer_del » 19 Oct 2011, 12:18

i want know about you what do you do? your projects, and what do you do etc. actually i liked your work and contribution and want to attach with you. i am a vb6 programmer and i also want to learn more about win32 api i want to learn so i could also make thing like you.

if you will teach me i'll help to make this controls better and more powerful.

basically i am from India, Delhi and my name is Amaan, Male. i am 30 years old and my mail id is amy.del@ovi.com

if you help me to learn those techniqus i will be very greatfull to you and help you to make your project more powerful.

hope you consider about this

with best greetings
amaan :roll:

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Unicode IME Does Not Work

Post by TiKu » 19 Oct 2011, 17:26

My real name is Timo Kunze. I'm a software developer from Munich, Germany. At work, I use mainly VB6, but also C++ and C#.

This website with all those ActiveX controls is a hobby that I started about 11 years ago when I left school. At this time I knew only VB6 and started to write ExplorerTreeView 1.x. I decided to publish this control for free and it became a huge success. Later I studied computer science and decided to teach myself C++. As C++ is much more powerful, especially if you're developing ActiveX controls, I switched to C++. At university I had a job; we developed a VB6 application and often ran into the limitations of the Microsoft Common Controls and the intrinsic VB6 controls. So I began to develop more controls. As I worked on them not only at work, but also in my free time, I continued to publish those controls on my website. I did not want to provide support and do all this business stuff, so the controls remained free.
Since I have a fulltime job now, I do not have much time anymore to work on the controls.

As I wrote above, all controls except ExplorerTreeView 1.x are written in C++. Yes, I know alot about Win32 API and ExplorerTreeView 1.x is a very advanced VB6 program. But I do not have the time to really teach you. But you always can expect an answer if you ask me something.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Unicode IME Does Not Work

Post by TiKu » 14 Jul 2019, 12:59

This has been fixed with version 1.11.0.
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

Post Reply