Control issue after update

The place for threads about TimoSoft ButtonControls.
Post Reply
MaKapuf
Cadet
Posts: 4
Joined: 11 Mar 2013, 14:41

Control issue after update

Post by MaKapuf » 11 Mar 2013, 16:09

Hi TiKu,

The last version that I use in a vb6 project is v1.6.1 without problem (VB6 SP6 + Windows 7 Pro x64).
I decided to upgrade with the last version 1.8.6 today ( :D ) and my project doesn't work anymore ( :o ).

When I select "TimoSoft ButtonControls 1.8 (Unicode)" in the control selection tools, VB6 says "Object library not registered".
Could you please have a look to the following error:
Image


I tried to uninstall this new version (1.8.6), and reinstall it again but I have the same problem.
I tried to uninstall this new version (1.8.6), and reinstall previous version (1.6.1) and it works.

After some research on the web, I have eliminated the issue regarding Mscomctl.ocx and the update : http://support.microsoft.com/kb/2597986

Thank you very much in advance for your help,
and also, thank you very much for your excellent job done! :D


Regards,
MaKapuf

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Control issue after update

Post by TiKu » 12 Mar 2013, 06:53

Hi,

I'm not aware of any change that would make the controls require administrative rights, but I'm investigating this issue.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Control issue after update

Post by TiKu » 12 Mar 2013, 08:17

Do the VB6 sample projects that are included in the setup run? Or do they have the same problem?

I did a quick test inside a virtual machine with a fresh Windows 7 x64 SP1. I simply installed the controls and executed the VB6 samples. They ran fine. I have not yet installed VB6 inside the VM, maybe the problem occurs only inside the IDE?

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

MaKapuf
Cadet
Posts: 4
Joined: 11 Mar 2013, 14:41

Re: Control issue after update

Post by MaKapuf » 12 Mar 2013, 12:09

Ach, the samples ".vbp" included in ButtonControls setup doesn't run but all ".exe" in the folders "bin" runs perfectly.

I did a full test with a fresh install of Windows 7 x64 SP1 + VB6 SP6 in VirtualBox and all is OK : my project and the samples included in ButtonControls setup runs perfectly.

So, the issue comes from my IDE or from my current Windows installation...
(And I would like to find why instead of reinstall Windows :mrgreen: do you have any idea?)

Thanks TiKu,

BR
MaKapuf

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Control issue after update

Post by TiKu » 12 Mar 2013, 22:03

The VB6 IDE creates oca files for the ocx files that it loads. Sometimes it helps to delete those oca files. Another thing you could try is to monitor the registry accesses with SysInternals ProcMon. There has to be some important access that fails. But this kind of analyzing is very time-consuming.

Best regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Control issue after update

Post by TiKu » 12 Mar 2013, 23:22

By the way, I've installed VB6 on the Win7 VM and can't detect any problem. I've run the samples from the IDE, I've compiled them and so on. I've also tried with different UAC settings. The only thing that I've learned during those tests is that it's best to always start the VB6 IDE with administrator rights. And if you then compile the project, you should be careful to not select a folder from the administrator's user profile. Otherwise you might end up searching the compiled program in the wrong directory.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

User avatar
TiKu
Administrator
Administrator
Posts: 832
Joined: 28 Sep 2004, 21:10
Location: Unterföhring
Contact:

Re: Control issue after update

Post by TiKu » 15 Mar 2013, 19:36

Hi,

could it be that you've installed MS Office 2003? I've read on a German VB6 forum that there are two security updates for MS Office 2003 that can cause such problems with VB6: KB2726929 and KB2597112.

Regards
TiKu
Crunching for Fab36_Folding-Division at Folding@Home. Join Fab36/Fab30! - Folding@Home and BOINC
Boycott DRM! Boycott HDCP!

MaKapuf
Cadet
Posts: 4
Joined: 11 Mar 2013, 14:41

Re: Control issue after update

Post by MaKapuf » 17 Mar 2013, 23:10

Hi,

Finally I decided to reinstall Windows 7 x64 and I've got the same problem! However I have fixed it by following these steps:

Right click the "VB6.exe" program file, and select properties from the context menu, click on the Compatibility tab and enable checkboxes:

- Run this program in compatibility mode for Windows XP (SP3)
- Disable Visual Themes
- Disable Desktop Composition
- Disable display scaling on high DPI settings
- Run this program in administrator mode (please note that I am already local administrator)


Result: All the ".vbp" samples files included in ButtonControls setup runs perfectly!! :D


The thing that I do not understand is that 1 hour after, I turned off the compatibility settings previously enabled and everything still runs...
(note that I am local administrator)
I have restarted the computer and everything still works perfectly with or without Compatibily settings.

--> It is like if the IDE had needed to register once OCX files. :?:


At last, I included the "vb6.exe.manifest file" in the VB6 folder in order to be able to use special features of comctl32.dll within the IDE.

The positive is that everything is OK, your OCX controls runs like a charm and I have got more than 15 Go of free space with a fresh reinstall of Windows 7 x64 :mrgreen:

Thanks TiKu for your support and thanks again for your wonderfull work.

Regards,
MaKapuf

arayaa
Cadet
Posts: 3
Joined: 19 Mar 2013, 18:12

Re: Control issue after update

Post by arayaa » 19 Mar 2013, 18:14

I am having a similar problem with the combolistbox control when trying to upgrade from v1.1 to v1.2.4 on VB6. :(

Post Reply